$re = '/([1-9]|0[1-9]|1[0-2])\/([1-9]|0[1-9]|1\d|2\d|3[01])\/(((19|2[0-4])\d{2})|2500)/';
$str = 'Dates between 1900 to 2500
12/1/2400
01/1/2001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);