$re = '/(?:\G(?!\A)|\()[^()]*?\Koops/m';
$str = 'bla bla bla (bla oops bla
bla bla oops bla oops
bla bla bla) bla oops
bla bla bla
oops bla (bla bla oops
bla)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);