import re
regex = re.compile(r"(?:\G(?!\A)|\()[^()]*?\Koops", flags=re.MULTILINE)
test_str = ("bla bla bla (bla oops bla\n"
"bla bla oops bla oops\n"
"bla bla bla) bla oops\n"
"bla bla bla \n"
"oops bla (bla bla oops\n"
"bla)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")