#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mUx)(?:" & @CRLF & _
"(?:" & @CRLF & _
"::(?:[0-9a-f]{1,4}:){0,5}|" & @CRLF & _
"[0-9a-f]{1,4}::(?:[0-9a-f]{1,4}:){0,4}|" & @CRLF & _
"(?:[0-9a-f]{1,4}:){2}:(?:[0-9a-f]{1,4}:){0,3}|" & @CRLF & _
"(?:[0-9a-f]{1,4}:){3}:(?:[0-9a-f]{1,4}:){0,2}|" & @CRLF & _
"(?:[0-9a-f]{1,4}:){4}:(?:[0-9a-f]{1,4}:)?|" & @CRLF & _
"(?:[0-9a-f]{1,4}:){5}:|" & @CRLF & _
"(?:[0-9a-f]{1,4}:){6}" & @CRLF & _
")" & @CRLF & _
"(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9]{1,2})\.){3}" & @CRLF & _
"(?:25[0-5]|2[0-4][0-9]|[01]?[0-9]{1,2})|" & @CRLF & _
"" & @CRLF & _
":(?::|(?::[0-9a-f]{1,4}){1,7})|" & @CRLF & _
"[0-9a-f]{1,4}:(?::|(?::[0-9a-f]{1,4}){1,6})|" & @CRLF & _
"(?:[0-9a-f]{1,4}:){2}(?::|(?::[0-9a-f]{1,4}){1,5})|" & @CRLF & _
"(?:[0-9a-f]{1,4}:){3}(?::|(?::[0-9a-f]{1,4}){1,4})|" & @CRLF & _
"(?:[0-9a-f]{1,4}:){4}(?::|(?::[0-9a-f]{1,4}){1,3})|" & @CRLF & _
"(?:[0-9a-f]{1,4}:){5}(?::|(?::[0-9a-f]{1,4}){1,2})|" & @CRLF & _
"(?:[0-9a-f]{1,4}:){6}(?::|(?::[0-9a-f]{1,4}))|" & @CRLF & _
"(?:[0-9a-f]{1,4}:){7}:|" & @CRLF & _
"(?:[0-9a-f]{1,4}:){7}[0-9a-f]{1,4}" & @CRLF & _
")" & @CRLF & _
"(?:%[0-9a-z]+)?"
Local $sString = "2001:db8::2a:15f:2adf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")