const regex = /^(?=.*\$val)(\$val|[-+*\/%|&=<> \d])+$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*\\$val)(\\$val|[-+*\\\/%|&=<> \\d])+$', 'mg')
const str = `For example:
\$val > 100 && \$val % 2 === 0
\$val + 2 === 0
\$val - 2 === 0
\$val * 2 === 0
\$val / 2 === 0
\$val | 2 === 0
\$val & 2 === 0
\$val < 2 === 0
\$val > 2 === 0
\$val = 2 === 0
should be accepted, but
10 > 100 && 20 === 30
not (due to absense of \$val variable)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}