import Foundation
let pattern = #"^(?=.*\$val)(\$val|[-+*\/%|&=<> \d])+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
For example:
$val > 100 && $val % 2 === 0
$val + 2 === 0
$val - 2 === 0
$val * 2 === 0
$val / 2 === 0
$val | 2 === 0
$val & 2 === 0
$val < 2 === 0
$val > 2 === 0
$val = 2 === 0
should be accepted, but
10 > 100 && 20 === 30
not (due to absense of $val variable)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)