$re = '/"[^"]*"|[^\s"]+|\s+/m';
$str = 'ADD r2, r3
ADD r2, r3" "foo bar
ADD r2, r3 "ADD r2, r3"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);