re = /"[^"]*"|[^\s"]+|\s+/m
str = 'ADD r2, r3
ADD r2, r3" "foo bar
ADD r2, r3 "ADD r2, r3"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end