using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[A-C]{3}$)(?!.*(.).*\1).*$";
string input = @"ABC
DEF
GHI
ACB
BAC
BCA
CAB
CBA
1234
GGFF
GABC
345";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}