$re = '/^(?=[A-C]{3}$)(?!.*(.).*\1).*$/m';
$str = 'ABC
DEF
GHI
ACB
BAC
BCA
CAB
CBA
1234
GGFF
GABC
345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);