import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\"id\\.resp_h\"[\"\\[:]*|\"rx_hosts\"[\"\\[:]*)(\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})";
final String string = "schema_id=17127524534057985804:skip_writers=\"\":{\"_path\":\"conn\",\"_system_name\":\"hostname\",\"_write_ts\":\"2020-01-12T22:09:28.853417Z\",\"ts\":\"2020-01-12T22:07:14.642074Z\",\"uid\":\"Cm4cbmvRjlmd2I52c\",\"id.orig_h\":\"192.168.1.1\",\"id.orig_p\":xxx,\"id.resp_h\":\"192.168.1.2\",\"id.resp_p\":xxx,\"proto\":\"udp\",\n\n"
+ "schema_id=17223896091372211545:skip_writers=\"\":{\"_path\":\"files\",\"_system_name\":\"Hostname\",\"_write_ts\":\"2020-01-12T22:09:00.016260Z\",\"ts\":\"2020-01-12T22:07:14.108217Z\",\"fuid\":\"FnmzOv3Fkhr8lP0qL\",\"tx_hosts\":[\"192.168.1.1\",\"192.168.1.1\"],\"rx_hosts\":[\"192.168.1.10\"],";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}