# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\"id\.resp_h\"[\"\[:]*|\"rx_hosts\"[\"\[:]*)(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})"
test_str = ("schema_id=17127524534057985804:skip_writers=\"\":{\"_path\":\"conn\",\"_system_name\":\"hostname\",\"_write_ts\":\"2020-01-12T22:09:28.853417Z\",\"ts\":\"2020-01-12T22:07:14.642074Z\",\"uid\":\"Cm4cbmvRjlmd2I52c\",\"id.orig_h\":\"192.168.1.1\",\"id.orig_p\":xxx,\"id.resp_h\":\"192.168.1.2\",\"id.resp_p\":xxx,\"proto\":\"udp\",\n\n"
"schema_id=17223896091372211545:skip_writers=\"\":{\"_path\":\"files\",\"_system_name\":\"Hostname\",\"_write_ts\":\"2020-01-12T22:09:00.016260Z\",\"ts\":\"2020-01-12T22:07:14.108217Z\",\"fuid\":\"FnmzOv3Fkhr8lP0qL\",\"tx_hosts\":[\"192.168.1.1\",\"192.168.1.1\"],\"rx_hosts\":[\"192.168.1.10\"],")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.