re = /^[A-Za-z0-9\ ,]+\.1/m
str = '1082805252197942751,34225793738713276,serialtooldata,1,Goals,75512140,125.0,63.0,29.0,1,,,,0,899,,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end