const regex = /^media\_(\w+?)(?:\_|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^media\\_(\\w+?)(?:\\_|$)', 'gm')
const str = `media_voice_message
media_photo
media_audio_file
media_video`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}