import re
regex = re.compile(r"^media\_(\w+?)(?:\_|$)", flags=re.MULTILINE)
test_str = ("media_voice_message\n"
"media_photo\n"
"media_audio_file\n"
"media_video")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")