package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z0-9._%+-]+@[a-z0-9.-]+\.[a-z]{2,4}$`)
var str = `// Allowed
one@a.com
one.two@ab.com
one.two@abc.ab
one.two@abc.abc
one.two@abc.abcd
a1_b2@abc.abc
a1b2@ab-cd.abc
a1b2@abcd.ab.cd
// Not allowed
one.two@abc.a
one.two@abc.abcde
one.two@abc.12
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}