$re = '/^[a-zA-Z]([a-zA-Z0-9]|(_(?!_)))+[a-zA-Z0-9]$/m';
$str = 'as23142
as231 qwdcasd
asdc_sdcsad
asd_
asd__scsd
a
b
ab
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);