import re
regex = re.compile(r"^[a-zA-Z]([a-zA-Z0-9]|(_(?!_)))+[a-zA-Z0-9]$", flags=re.MULTILINE)
test_str = ("as23142\n"
"as231 qwdcasd\n"
"asdc_sdcsad\n"
"asd_\n"
"asd__scsd\n"
"a\n"
"b\n"
"ab\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")