const regex = /(\d+)[a-z]\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)[a-z]\\b', 'gi')
const str = `{Rotation:[45f,90f],lvl:10s}`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);