import Foundation
let pattern = #"(\d+)[a-z]\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"{Rotation:[45f,90f],lvl:10s}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)