const regex = /^\d+([.,]\d+)?$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+([.,]\\d+)?$', 'mg')
const str = `12345
1.2344
1,2345
+123.34@@##sdsd
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}