$re = '/^\d+([.,]\d+)?$/m';
$str = '12345
1.2344
1,2345
+123.34@@##sdsd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);