$re = '/Overlord([^\w])+(\w+)([^\w]+|)([0-9])+(\W*)/m';
$str = 'Overlord Vol. 1: The Undead King
Overlord, Volume 1: The Undead King
Overlord, Vol 1: The Undead King
Overlord, Vol1: The Undead King
Overlord Vol1: The Undead King
Overlord: Volume 1: The Undead King
Overlord- Volume 1: The Undead King
Overlord Vol1: The Undead King
Overlord Vol 45
Overlord Vol 02
The Bad Volume are too high
Overlord Vol12: The Undead King
Overlord - Volume 17';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);