import Foundation
let pattern = #"Overlord([^\w])+(\w+)([^\w]+|)([0-9])+(\W*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Overlord Vol. 1: The Undead King
Overlord, Volume 1: The Undead King
Overlord, Vol 1: The Undead King
Overlord, Vol1: The Undead King
Overlord Vol1: The Undead King
Overlord: Volume 1: The Undead King
Overlord- Volume 1: The Undead King
Overlord Vol1: The Undead King
Overlord Vol 45
Overlord Vol 02
The Bad Volume are too high
Overlord Vol12: The Undead King
Overlord - Volume 17
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)