import Foundation
let pattern = #"(\d{2}\/\d{2}\/\d{2})\s(\d{2}\:\d{2})\s(\d+)\s(Allow|Reject)\s(.*)(\d+)\s(tcp|udp)\s(.*)\s(.*)\s(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"09/21/11 10:47 29 Allow Partner-SQL-eComm 46990 tcp Partner-Web-eComm mysql 19999"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)