package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s+|\s+$|[^\S ]`)
var str = ` abc def ghi `
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}