$re = '/^\s+|\s+$|[^\S ]/u';
$str = ' abc def ghi ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;