$re = '/^(?=[ple]*a)(?=[ape]*l)(?=[apl]*e)(?=[ale]*p[ale]*p)[aple]{5}$/mi';
$str = 'Apple
ppleA
APPLE
apple
ppale
foo
appple
aple
bar
test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);