re = /^(?=[ple]*a)(?=[ape]*l)(?=[apl]*e)(?=[ale]*p[ale]*p)[aple]{5}$/mi
str = 'Apple
ppleA
APPLE
apple
ppale
foo
appple
aple
bar
test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end