re = /\\hyperlink{[^}{]*}{[^}{]*(?:{[^}{]*}[^}{]*)*}/m
str = 'Use \\hyperlink{aaa}{apple {pear} banana} and \\hyperlink{bbb}{banana {pear} {apple}}.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end