$re = '/(?s)(apple)(?:(?!\1).)*orange/m';
$str = 'apple
lemon
apple
banana
orange
avocado';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);