re = /(?s)(apple)(?:(?!\1).)*orange/m
str = 'apple
lemon
apple
banana
orange
avocado'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end