package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:2[3-9]|3[0-9]|40)\b`)
var str = `20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}