re = /\b(?:2[3-9]|3[0-9]|40)\b/m
str = '20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end