#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^http(s)?:\/\/([^\/]+)"
Local $sString = "https://kdl.ru/patient/blog/omega-3-piti-ili-ne-piti" & @CRLF & _
"https://apteka-april.ru/blog/intresting-and-useful/37-chto-takoe-omega-3" & @CRLF & _
"https://galina-erikson.ru/poleznye-dlya-zdorovya-stati/a-vy-znaete-kak-pravilno-vybrat-preparat-omega-3" & @CRLF & _
"https://omega-labs.ru/" & @CRLF & _
"https://www.sportfood40.ru/articles/kak-vybrat-omega-3/" & @CRLF & _
"https://www.kp.ru/expert/elektronika/luchshie-noutbuki-dlya-raboty/" & @CRLF & _
"https://yandex.ru/video/preview/11052470352245519618?text=какой ноутбук купить для работы&path=yandex_search&parent-reqid=1678203470996582-5656932453459637239-sas3-0967-c7e-sas-l7-balancer-8080-BAL-6300&from_type=vast" & @CRLF & _
"https://www.OZON.ru/club/article/roboty-pylesosy-reyiting-modeleyi-dlya-chistoty-v-kvartire-16303710/" & @CRLF & _
"https://рейтинг-лучшего.рф/rejtingi/luchshie-detskie-smart-chasy/" & @CRLF & _
"https://mobilegadjet.ru/sravneniya/2340-"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")