// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^http(s)?:\/\/([^\/]+)").unwrap();
let string = "https://kdl.ru/patient/blog/omega-3-piti-ili-ne-piti
https://apteka-april.ru/blog/intresting-and-useful/37-chto-takoe-omega-3
https://galina-erikson.ru/poleznye-dlya-zdorovya-stati/a-vy-znaete-kak-pravilno-vybrat-preparat-omega-3
https://omega-labs.ru/
https://www.sportfood40.ru/articles/kak-vybrat-omega-3/
https://www.kp.ru/expert/elektronika/luchshie-noutbuki-dlya-raboty/
https://yandex.ru/video/preview/11052470352245519618?text=какой ноутбук купить для работы&path=yandex_search&parent-reqid=1678203470996582-5656932453459637239-sas3-0967-c7e-sas-l7-balancer-8080-BAL-6300&from_type=vast
https://www.OZON.ru/club/article/roboty-pylesosy-reyiting-modeleyi-dlya-chistoty-v-kvartire-16303710/
https://рейтинг-лучшего.рф/rejtingi/luchshie-detskie-smart-chasy/
https://mobilegadjet.ru/sravneniya/2340-";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}