import Foundation
let pattern = #"^([^\\]*\\[^\\]*).*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Conversation with Jared Firl\nParticipants: Jared Firl\nJared FirlThursday, March 27, 2014 at 8:30pm MDT\n\nAlready got it for super cheap from a humble bundle. But thanks for the thought!\nBen James PerryThursday, March 27, 2014 at 8:29pm MDT\n\nYo jared, since you were kind enough to mention the left 4 dead thingy on Christmas, Dead space is free on origin"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)