using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^""\\]*(?:\\[\s\S][^""\\]*)*""";
string input = @"""String \"" int""
""String \\\"" \
int""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}