re = /"[^"\\]*(?:\\[\s\S][^"\\]*)*"/
str = '"String \\" int"
"String \\\\\\" \\
int"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end