using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href=""\/(?<category>.+?)\/(?<name>.+?)\/"">(?<title>.+?)<\/a>";
string input = @"<a href=""/clothing/jacket/"">Jacket</a>
<a href=""/clothing/Socks/"">Socks</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}