$re = '/<a href="\/(?<category>.+?)\/(?<name>.+?)\/">(?<title>.+?)<\/a>/m';
$str = '<a href="/clothing/jacket/">Jacket</a>
<a href="/clothing/Socks/">Socks</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);