#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[NT_BASIC](?:,\[[^\r\n\]]*])*(?:\r?\n(?!\r?\n\[).*)*\r?\n"E:""
Local $sString = "[NT_BASIC]" & @CRLF & _
""SYSTEM" WARNING 1 GB * 0000 2400" & @CRLF & _
""SYSTEM" MINOR 500 MB * 0000 2400" & @CRLF & _
"" & @CRLF & _
"[OTHERS],[DB2]" & @CRLF & _
""D:" WARNING 1 GB * 0000 2400" & @CRLF & _
""D:" MINOR 500 MB * 0000 2400" & @CRLF & _
""E:" WARNING 1 GB 1-5 0700 1700" & @CRLF & _
""E:" MINOR 500 MB 1-5 0700 1700" & @CRLF & _
""F:" WARNING 5 % 1-5 0700 1700" & @CRLF & _
""F:" MINOR 2 % 1-5 0700 1700" & @CRLF & _
""H:" WARNING 1 GB 1-5 0700 1700" & @CRLF & _
""H:" MINOR 500 MB 1-5 0700 1700" & @CRLF & _
"" & @CRLF & _
"[NT_BASIC]" & @CRLF & _
""SYSTEM" WARNING 1 GB * 0000 2400" & @CRLF & _
""SYSTEM" MINOR 500 MB * 0000 2400" & @CRLF & _
""E:" WARNING 1 GB 1-5 0700 1700" & @CRLF & _
"" & @CRLF & _
"[OTHERS],[DB2]" & @CRLF & _
""D:" WARNING 1 GB * 0000 2400" & @CRLF & _
""D:" MINOR 500 MB * 0000 2400" & @CRLF & _
""E:" WARNING 1 GB 1-5 0700 1700" & @CRLF & _
""E:" MINOR 500 MB 1-5 0700 1700" & @CRLF & _
""F:" WARNING 5 % 1-5 0700 1700" & @CRLF & _
""F:" MINOR 2 % 1-5 0700 1700" & @CRLF & _
""H:" WARNING 1 GB 1-5 0700 1700" & @CRLF & _
""H:" MINOR 500 MB 1-5 0700 1700"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")