# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\[NT_BASIC](?:,\[[^\r\n\]]*])*(?:\r?\n(?!\r?\n\[).*)*\r?\n\"E:\""
test_str = ("[NT_BASIC]\n"
"\"SYSTEM\" WARNING 1 GB * 0000 2400\n"
"\"SYSTEM\" MINOR 500 MB * 0000 2400\n\n"
"[OTHERS],[DB2]\n"
"\"D:\" WARNING 1 GB * 0000 2400\n"
"\"D:\" MINOR 500 MB * 0000 2400\n"
"\"E:\" WARNING 1 GB 1-5 0700 1700\n"
"\"E:\" MINOR 500 MB 1-5 0700 1700\n"
"\"F:\" WARNING 5 % 1-5 0700 1700\n"
"\"F:\" MINOR 2 % 1-5 0700 1700\n"
"\"H:\" WARNING 1 GB 1-5 0700 1700\n"
"\"H:\" MINOR 500 MB 1-5 0700 1700\n\n"
"[NT_BASIC]\n"
"\"SYSTEM\" WARNING 1 GB * 0000 2400\n"
"\"SYSTEM\" MINOR 500 MB * 0000 2400\n"
"\"E:\" WARNING 1 GB 1-5 0700 1700\n\n"
"[OTHERS],[DB2]\n"
"\"D:\" WARNING 1 GB * 0000 2400\n"
"\"D:\" MINOR 500 MB * 0000 2400\n"
"\"E:\" WARNING 1 GB 1-5 0700 1700\n"
"\"E:\" MINOR 500 MB 1-5 0700 1700\n"
"\"F:\" WARNING 5 % 1-5 0700 1700\n"
"\"F:\" MINOR 2 % 1-5 0700 1700\n"
"\"H:\" WARNING 1 GB 1-5 0700 1700\n"
"\"H:\" MINOR 500 MB 1-5 0700 1700")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.