re = /(http(s)?:\/\/.)?(www\.)?[-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z]{2,6}\b([-a-zA-Z0-9@:%_\+.~#?&\/\/=]*)/m
str = 'Get URL: www.lapagina.com, pagina.com, http://www.lapagina.com, http://pagina.com https://mypag.us'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end