re = /^(?![a-zA-Z]+$).*/m
str = 'abcba1a
111111111111111111111
aaaaaaaaveeEEEEEEEE
ZzZ1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end