$re = '@(?<=>\\\\\\\\%name%)(.*)(?=<)@';
$str = '<Tag>\\\\%name%\\TST$\\Program\\1.0\\000\\Program.msi</Tag>
<Tag>/i /L*V "%TST%\\filename.log" /quiet /norestart</Tag>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);