re = /(?<=>\\\\%name%)(.*)(?=<)/
str = '<Tag>\\\\%name%\\TST$\\Program\\1.0\\000\\Program.msi</Tag>
<Tag>/i /L*V "%TST%\\filename.log" /quiet /norestart</Tag>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end