package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<serialCode>[a-zA-Z0-9]{3})(?:(?<serialMarket>[a-zA-Z]{2})(?<serialSuffix>[a-zA-Z0-9]*))?`)
var str = `abcfobar
abc33bar
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}