re = /^(?<serialCode>[a-zA-Z0-9]{3})(?:(?<serialMarket>[a-zA-Z]{2})(?<serialSuffix>[a-zA-Z0-9]*))?/m
str = 'abcfobar
abc33bar
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end