#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.)(?!\1)(.)(?!\1)(?!\2)(.)(?!\1)(?!\2)(?!\3)(.)(?!\1)(?!\2)(?!\3)(?!\4)(.)(?!\1)(?!\2)(?!\3)(?!\4)(?!\5)(.)(?!\1)(?!\2)(?!\3)(?!\4)(?!\5)(?!\6)(.)(?!\1)(?!\2)(?!\3)(?!\4)(?!\5)(?!\6)(?!\7)(.)(?!\1)(?!\2)(?!\3)(?!\4)(?!\5)(?!\6)(?!\7)(?!\8)(.)(?!\1)(?!\2)(?!\3)(?!\4)(?!\5)(?!\6)(?!\7)(?!\8)(?!\9)(.)(?!\1)(?!\2)(?!\3)(?!\4)(?!\5)(?!\6)(?!\7)(?!\8)(?!\9)(?!\10)(.)(?!\1)(?!\2)(?!\3)(?!\4)(?!\5)(?!\6)(?!\7)(?!\8)(?!\9)(?!\10)(?!\11)(.)(?!\1)(?!\2)(?!\3)(?!\4)(?!\5)(?!\6)(?!\7)(?!\8)(?!\9)(?!\10)(?!\11)(?!\12)(.)(?!\1)(?!\2)(?!\3)(?!\4)(?!\5)(?!\6)(?!\7)(?!\8)(?!\9)(?!\10)(?!\11)(?!\12)(?!\13)(.)"
Local $sString = "mjqjpqmgbljsphdztnvjfqwrcgsmlb: first marker after character 19" & @CRLF & _
"bvwbjplbgvbhsrlpgdmjqwftvncz: first marker after character 23" & @CRLF & _
"nppdvjthqldpwncqszvftbrmjlhg: first marker after character 23" & @CRLF & _
"nznrnfrfntjfmvfwmzdfjlvtqnbhcprsg: first marker after character 29" & @CRLF & _
"zcfzfwzzqfrljwzlrfnpqdbhtmscgvjw: first marker after character 26" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")